Before your install WP E-Signature, you should check out out server requirements below!

You should also check WordPress’ minimum requirements.

WP E-Signature requires WordPress 3.5 minimum.