We LOVE security here at WP E-Signature! We dream about it… think about it… talk about it… breathe it.

When sending and signing legally binding documents using a self-hosted solution, security should also be one of YOUR top #1 concerns. Because security is such a big deal to us…

WP E-signature requires WordPress version 4.5 or greater!

To learn more about updating WordPress you can checkout this article:
https://codex.wordpress.org/Updating_WordPress

Before you update WordPress or ANY plugin, you should always make sure that you have a backup of the database, should any errors or complications arise from your update. We highly recommend using the Duplicator WordPress Backup Plugin (which has over 700,000 installs). It can automatically backup to Dropbox, AWS, Google Drive, ftp, etc.